cacti rrdtool snmp 版本错误问题
最近新安装了cacti 0.8.7e发现了个很莫名的问题:无法画图并且主机检测snmp error在Console...
扫描右侧二维码阅读全文
12
2010/03

cacti rrdtool snmp 版本错误问题

最近新安装了cacti 0.8.7e

发现了个很莫名的问题:无法画图并且主机检测snmp error

在Console -> Utilities -> Technical Support中发现:

snmp  Version:显示为空

RRDTool Version:ERROR: Installed RRDTool version does not match configured version.
Please visit the Configuration Settings and select the correct RRDTool Utility Version.

排查所有可能引起的问题。php 模块,rrdtool也从1.4换到1.3再到1.2.30搞郁闷啦。

最后到官网发现原来是0.8.7e的bug 打了官方补丁后ok啦。虽然Technical Support中还是显示错误,但可以画图和snmp检测主机啦。
以下脚本,大家如果发现有同样问题,可以复制保存为sh文件在cacti web目录中执行即可。
wget http://www.cacti.net/downloads/patches/0.8.7e/cli_add_graph.patch wget http://www.cacti.net/downloads/patches/0.8.7e/snmp_invalid_response.patch wget http://www.cacti.net/downloads/patches/0.8.7e/template_duplication.patch wget http://www.cacti.net/downloads/patches/0.8.7e/fix_icmp_on_windows_iis_servers.patch wget http://www.cacti.net/downloads/patches/0.8.7e/cross_site_fix.patch patch -p1 -N < cli_add_graph.patch patch -p1 -N < snmp_invalid_response.patch patch -p1 -N < template_duplication.patch patch -p1 -N < fix_icmp_on_windows_iis_servers.patch patch -p1 -N < cross_site_fix.patch

Last modification:November 26th, 2018 at 04:16 pm
If you think my article is useful to you, please feel free to appreciate

Leave a Comment